标签归档 » cocos2d-x

CDC北京演讲“页游转型手游之路”的相关PPT和内容

本来我是写了挺多的演讲内容的,不过当我上场之后就开始自由发挥了,所以导致的一个结果是我的演讲内容和我想好的内容只有不到一半的重合度,我其实还可以演示一下player的用法和各个示例的效果,还可以播放一下UI编辑器的演示视频的。以下是我写好的 …..

在quick-cocos2d-x中添加自定义的类给lua使用

由于quick本身有些东西是不提供的,我们需要加入自己定义的或是第三方的类库去给lua使用,于是需求就是自己定义一个类提供给lua使用。 需求有了,于是就去找相关的资料,在官方找到一句话:“请参考 quick 项目 lib/co …..

Quick-cocos2d-x一步一步教你入门

quick-cocos2d-x 是一个可以让您觉得“爽快”的 cocos2d-x 的扩展版。基于 cocos2d-x,完全的跨平台能力、优异的性能和可靠性。而 quick-cocos2d-x 在这一切的基础上,添加了完善的 Lua 脚本语言支持,让开发者可以使用 Lua 这种简单易用的脚本语言完成商业品质的移动游戏。

cocos2d-x+Plugin-X插件集成指南(安卓版)

最近cocos2d-x官网放出了plugin-x的官方指南,不过官网为了国际化,都是用英文写的,既然cocos2d-x的主要使用群体是中国人,而且是中国人主导的开发项目,为什么不考虑实际情况同步放出中文的指南呢?不得不说他们全英文的做法一下子就让B格提升了。下面开始正文

由于我的目的不是单纯地翻译官方的文章,所以请读者不要用原文翻译的标准来要求我,不喜勿看,欢迎来喷。

NDK无法生成libgame.so的问题根源和解法方法

xcode下编码完全没有问题,在模拟器上运行正常

在eclipse下编译无法生成libgame.so文件,具体的报错是:

undefined reference to vtable

怎么样升级cocos2d-x的版本

cocos2d-x的安装脚本里没有升级的脚本,我们如果在新版本安装的时候加上参数:-f 强制安装也没有能完全解决问题。新建项目的时候看到版本还是旧的。经过搜索,从网上找到一些资料,我参考了这个链接上的内容:http://www.cocoachina.com/bbs/read.php?tid=100540,但是操作了之后也没有完全解决问题。不过最后我把问题解决了。下面我说一下我的解决步骤供大家参考